Installation et Configuration de MPLAB X IDE

De Wiki_du_Réseau_des_Electroniciens_du_CNRS
Aller à : navigation, rechercher


Installation et configuration de MPLAB® X IDE

  • MPLAB® X IDE est l'environnement de développement pour microcontrôleur PIC. Vous pouvez le télécharger à l'adresse www.microchip.com/mplabx [1]

Si une version précédente de MPLAB® X IDE est installé sur votre machine, commencez d'abord par la désinstaller, de même pour les compilateurs, bien que pour ces derniers il soit possible d'avoir plusieurs version d'un même compilateur.

Installer ensuite un compilateur C en fonction du type d'architecture du microcontrôleur à programmer: 8, 16 ou 32 bits

  • MPLAB® XC8 Compiler, voir MPLAB® C18 Lite Compiler for PIC18 MCUs afin de compiler les projets existant sur le SVN du RE
GT PIC MPLAB XC8 Setup.jpg
  • MPLAB® XC16 Compiler
  • MPLAB® XC32 Compiler
GT PIC MPLAB XC32 Setup.jpg


De nombreux exemples et ressources sont également disponible dans le package à installer "Microchip Libraries of Applications" [2]


Après l'installation

Vous pourrez avoir besoin de mettre à jour les chemins vers les répertoires d'installations des compilateurs après en avoir désinstallé, puis ré-installé de nouveaux. Pour ce faire, voici comment procéder: Allez dans le menu "Tools > Options" de MPLAB® X IDE, puis dans l'onglet "Build Tools" de la section "Embedded", enfin cliquez sur "Scan for Build Tools" comme illustré par les capture d'écran.

GT PIC MPLAB XC32 Add Path 1.jpg
GT PIC MPLAB XC32 Add Path 2.jpg


MPLAB® X IDE est configuré de façon à ce que la mise en page du code source soit respecté (conversion des tabulations en 4 caractères d'espaces)

Voir le menu "Tools" puis sélectionnez "Options" onglet "Editor", la case "Expand Tabs to Spaces" indique que lors de l'insertion d'une tabulation, celle-ci sera remplacé par 4 caractères d'espaces.


=== Le groupe PIC ===
Présentation du Groupe de Travail   >Premiers pas  >Document   >Tutoriel   >Librairie   >Demo   >Projet   >TODO